Longer Response Times Due to Email Service Disruptions

Incident Report for Avima

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 16:14 CET

Identified

Certain system features that generate notifications are experiencing longer response times than usual due to disruptions at our email service provider. We are monitoring the situation and will provide updates as we learn more. Thank you for your patience.
Posted Mar 17, 2025 - 15:28 CET
This incident affected: Avima.